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1. Introduction 

Purpose 

 
This document outlines the process of configuring the software integration between Genetec Security 
Center (GSC) and Invixium’s IXM WEB. 
 

Summary of key features related to this IXM WEB and GSC Integration 

• Setting Web-based SDK   

• ‘Sync All’ feature to resynchronize the database from GSC to IXM WEB 

• ‘IXM WEB AddOn’ facility for Biometric Enrollment from GSC  

• Multiple Card Support upto 10 cards (default card formats of GSC)  

• RIO Integration for wireless connection 

 

Description 

IXM Link, a licensed module in IXM WEB, is required to synchronize the user database between IXM 

WEB (where biometric enrollment for users is performed) and Genetec Security Center Software 

(where access rules for the users and the organization are managed). 

 

Note: To activate IXM Link within IXM WEB, the installer must contact Invixium Support at 

support@invixium.com to obtain the activation key. 

 

The following sections will describe how to set up and configure IXM Link to keep IXM WEB users in 

sync with Security Center by using Genetec Web-based SDK. 

 

Acronyms 

Acronym Description 

ACPCS Access Control Panel Configuration Software 

GSC Genetec Security Center 

IXM Invixium 

Field Mappings 

The following are the GSC fields that are mapped to IXM WEB: 

mailto:support@invixium.com
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GSC Field IXM Field Notes 

First name First Name  

Last name Last Name  

Status Suspend User  

Activation Start Date  

Expiration 
End Date 

 
 

Card 
Number 

Prox ID/Smart Card ID Prox ID is given priority during export 

Facility 
Code 

Facility Code  

Email 
Address 

Email  

Bypass 
antipassback 
rules 

Anti-passback  

 
 
Note: Multiple Cards - GSC can have multiple cards per user, and IXM WEB supports a maximum of 

10 cards per user. IXM Link selects the available valid cards. 

2. Compatibility 

Invixium Readers 

TITAN TFACE TOUCH2 SENSE2 MERGE2 MYCRO 

All models All models All models All models All models All models 

Software Requirements 
 

Application Version 

Genetec Security Center v5.10.3 

Invixium IXM WEB 2.3.0.0 

Operating Systems Windows 10 (Build 1709+) Professional 

Version  

Windows Server 2016 Standard 

Windows Server 2019 

Supported but not recommended: 

(legacy) 
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Windows 8.1 

Windows Server 2012 R2 

Windows Server 2012 

Microsoft .NET Framework .NET Framework 4.8 

Database Engine SQL Server 2016+ 

Supported but not recommended: (legacy) 

SQL server 2014 Express Edition (Default 
Installation) 

Internet Information Services 
(IIS) 

Microsoft® Internet Information Services 
version 7.5 or higher 

Web Browser Google Chrome 
Mozilla Firefox 

Microsoft Edge (Internet Explorer not 
recommended) 

Other Requirements 
 

Server 2.4 GHz Intel Pentium or higher 

RAM 8 GB or higher 

Networking 10/100Mbps Ethernet connections 

 

 
Note: Server requirements mentioned are ideal for 10-15 devices registered with 500 employees or 

fewer. For large enterprise installation server requirements, contact support@invixium.com. 

 

Compatibility Matrix for IXM WEB & Security Center Integration 

 

IXM WEB version GSC version Compatible 

IXM WEB 2.2.57.0 v5.9.1 Yes 

IXM WEB 2.2.57.0 v5.10.3 Yes 

IXM WEB 2.2.224.0 v.5.9.1 Yes 

IXM WEB 2.2.224.0 v5.10.3 Yes 

IXM WEB 2.2.252.0 v5.10.3 Yes 

IXM WEB 2.2.330.0 v5.10.3 Yes 

IXM WEB 2.3.0.0 v5.10.3 Yes 

Table 1: Compatibility Matrix for IXM WEB & Genetec Integration 

mailto:support@invixium.com
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3. Checklist 

 

 

 

 

 

 

 

 

4. Task List Summary 

Task IXM WEB Application Task List 

using IXM WEB 

Genetec Security Center Task List 

using GSC 

1 
Activate IXM WEB and IXM Link for 

GSC 
Create Web-based SDK 

2 Configure IXM Link for GSC First time enrollment configuration 

3 
Register IXM Devices and configure 

settings as per the requirement 

Enroll cardholder biometric (Face, 

fingerprint, finger vein) 

4 

Configure Weigand or OSDP or RIO 

settings in device for integration 

with Genetec Synergies appliance 

Configuring door for RIO integration 

5 
Assign a specific Device Group to 

the device 
Monitor Events and Generate Report 

Table 2: Task List Summary 

Item List Interface 

Create Web-based SDK Genetec 

IXM WEB Activation ID Invixium 

SQL Instance on SQL Server 2016+ Invixium 

Install IXM WEB Application Invixium 

IXM WEB and IXM Link Activation Invixium 

Configure IXM Link to Genetec Invixium 

Configure Invixium Reader Invixium 

Face or Finger Enrollment Invixium 
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5. Prerequisites for GSC and IXM WEB Integration 

Setting up Web-based SDK 

Procedure 

STEP 1 

Navigate to System → Roles → Click Web-based SDK 

 

 
 

 

 

 

 

 

 

 

 

 

Figure 1: GSC – Setting up Web-Based SDK 
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6. Prerequisites for Installing Invixium IXM WEB Software 

Acquiring IXM WEB Activation Key 

Procedure 

STEP 1 

Complete the online form to receive instructions on how to download IXM WEB: 

https://www.invixium.com/download-ixm-web/. 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Figure 1: IXM WEB Online Request Form 

 

https://www.invixium.com/download-ixm-web/
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After submitting the completed form, an email will be sent with instructions from 

support@invixium.com to the email ID specified in the form.  

Please ensure to check the spam or junk folder. 

See below for a sample of the email that includes instructions on how to download and install 

IXM WEB along with your Activation ID. 

 

 

 

 

 

 

 

 

 

 

 

Figure 2: Sample Email After Submitting Online Request Form 

  

mailto:support@invixium.com
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Setting Up SQL instance 

Note: The following section describes the setup of a pre-created instance of SQL 2016+. Creating a 

new instance can be done with the use of SQL Installer within the Security Center installation media 

kit. 

 

Procedure 

 

STEP 1 

Make sure to Create a new SQL instance on the server. 

 

 

STEP 2 

Set the instance name as IXM WEB (default) or Invixium. 

 

 

STEP 3 

Select mixed mode: SQL Authentication and Windows Authentication for secure logins. Leave 

everything else as default. 

 

 

STEP 4 

Install SQL Management Studio on the server. 
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STEP 5 

Log into the new instance and create a new user. 

 

 

 

 

 

 

Figure 3: SQL New Login 

 

STEP 6 

Select SQL Server authentication. 

Note: Make sure to uncheck both ‘Enforce password expiration’ and ‘User must change password at 

next login’. 
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Figure 4: SQL Login Properties 
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STEP 7 

Add this user under Server Roles, dbcreator, and sysadmin. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5: SQL Server Roles 

RESULT 

These privileges will be used later in the installation process to create the database. 
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Minor Checklist and Considerations 

Use these tables to verify that you have carried out all required steps. 

 

Other Minor Checklist  

Windows Updates 

Windows Operating system needs to be up to date. 
 

System updates should not be pending. If any update is 
downloaded, you will have to restart the system to complete 
the Windows update. 

User Privileges 
The person who is setting up IXM WEB should have full 
administrator rights 

Table 3: System Related Checklist 

 

 

Port Assignment Port 

Inbound HTTP Port 9108 

TCP 1433 

Port to communicate 
between IXM WEB & 
Devices 

9734 

Inbound Port 1255 

GSC Web SDK Port 4590 (default) 

Table 4: Port Information 
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7. Installing IXM WEB 

Software Install 

Procedure 

STEP 1 

Run the IXM WEB installer (Run as administrator). 

Select Advanced. 

 

 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

Figure 6: IXM WEB Installer 

STEP 2 

Deselect Install SQL Server and select Install. 
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Figure 7: Advanced Options in IXM WEB Installer 
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STEP 3 

During the installation, you may see this message, click Install. 

 

 

 

 

 

 

 

Figure 8: Invixium Fingerprint Driver Installation Message 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9: IXM WEB Installation Progress 
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STEP 4 

After the installation completes, you should see the following screen: 

 

 

 

 

 

 

 

 

 

 

 

Click on the X in the upper right corner to close. 

 

Figure 10: IXM WEB Installation Completed 
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STEP 5 

Double click on the new desktop shortcut to open IXM WEB. 

 

 

  

 

 
Figure 11: IXM WEB Icon - Desktop Shortcut 

 

IXM WEB will open in your default browser (initial opening may take a few minutes). 

 

 

 

 

 

 

 

 

Figure 12: IXM WEB Database Configuration 

STEP 6 

Select the SQL Server authentication and the Server Name from the drop-down options. If it does not 

appear, enter it manually. 
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STEP 7 

Enter the user credentials created above and leave IXMDB as the database name.  

 

 

 

 

 

 

 

 

 

 

 

 

Figure 13: IXM WEB Administrator User Configuration 

 

Now comes the step to create the user account for Invixium to access the database itself. 

STEP 8 

Create a user account (this is different from the identity used to connect to the SQL instance at the 

top of the page). The status bar will indicate the strength of the chosen password. 

 

STEP 9 

Change http://localhost:9108 to http://[IP address of server]:9108 
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For example: 

If the IP address of the server is 192.168.1.100, then specify the Server URL as the following: 

http://192.168.1.100:9108 

 

STEP 10 

Click Save. The software will now create the database and continue setup. This could take several 

minutes. 
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STEP 11 

When IXM WEB is finished installing, you should be prompted with the following screen: 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 14: IXM WEB Login Page 

 

 

 

Note: During an upgrade of IXM WEB from any previous release to 2.3.0.0, an internet connection is 

required for license validation. As this new version includes a face algorithm update, it will 

automatically convert templates without the need for re-enrollment of faces. 
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8. Configuring Email Settings using IXM WEB 

Configuring Email settings is highly recommended as one of the first steps after installing IXM WEB. 

Email configuration settings will help the admin retrievie the password for IXM WEB in case it is 

forgotten. In addition, having email settings configured also makes activation and license key requests 

easier. 

Email Setting Configuration  

Procedure 

STEP 1 

Click Configure Email on the Login page.  

OR 

Expand the Left Navigation Pane → Navigate to Notification Settings → Email Configuration → 

Click Manage Preferences. 

 

 

 

 

 

 

 

 

 

 

 
Figure 15: Configure Email 
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STEP 2 

Select “Enable Email Configuration” and enter values for “SMTP Host”, “SMTP Port”, and “Send email 

message from” fields.  

 

 

 

 

 

 

 

 

 

 

Figure 16: IXM WEB - SMTP Settings 

 

Note: If Gmail/Yahoo/MSN etc. email servers are used for “SMTP Host” then “SMTP Login” and 

“SMTP Password” values need to be provided. Also in this case, “Secure Connection” needs to be set 

to either SSL or SSL/StartTLS. 

 

 

 

 

 

 

 



 
 
 
 
 
 
 

XAD-TPI-007-03G 
31 

STEP 3 

After entering the values, click Save to save the SMTP Settings on the IXM WEB database. 

 

 

 

 

 

 

Figure 17: IXM WEB - Save Email Settings 

 

To test the settings, Navigate to Notification Settings from the Left Navigation Pane → Go to Email 

Configuration → Click the Test Connection button on the right. 

  

 

 

 

 

Figure 18: IXM WEB - Test Connection 
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Provide a valid email address. Click Send to send a test email. 

 

 

 

 

 

 

 

Figure 19: IXM WEB - Enter Email ID 
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STEP 4 

Once email configuration is completed, a Forgot password link will appear on the Sign In page in its 

place.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 20: IXM WEB - Forgot Password 
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9. Software and Module Activation 

IXM WEB Activation 

 

Procedure 

STEP 1 

Log into IXM WEB. 

Figure 21: IXM WEB - Enter Login Credentials 
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STEP 2 

Select the License Tab and then select the IXM WEB module to request an activation key for IXM 

WEB. 

 

Figure 22: IXM WEB - License Setup 

 

STEP 3 

Request Activation Key Online or via Offline Activation Options. 

Note: The Activation ID is in the email received when registering. If online activation fails, check with 

your local IT as the client may be blocked by your network.  
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STEP 4 

Once the system is activated, the Status will be displayed as Active. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 23: IXM WEB - Online Activation 
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Security Center Module Activation 

The option to activate a Genetec Security Center License is available under the License tab. 

STEP 1 

Request a License. 

STEP 2 

From Home, expand the Left Navigation Pane, Go to the License tab. Click on Security Center 

(Genetec). 

 

 

 

Figure 24: IXM WEB - Genetec Link Activation 
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STEP 3 

You will receive an email from Invixium Support containing a license key for the Genetec Security 

Center Activation. 

 

 

 

 

 

 
 
 
 
 

 

 

 

  

Figure 25: Genetec License Key Email 
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STEP 4 

Copy and paste the License Key in the box provided, and then select Activate. 

 

                   

 

 

 

 

 

 

 

 

 

 

Figure 26: IXM WEB - Activate Genetec Link License 

 

RESULT  

IXM WEB is now licensed for use with Security Center and configuration can begin. 
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10. Configuring IXM Link for Genetec 

 
Procedure 

STEP 1 

From the Left Navigation Pane → Link → click the blue Security Center (Genetec) icon. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 27: IXM WEB - Link Menu 
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STEP 2 

Toggle the Status switch to enable.  

 

 

 

 

 

 

 

 

 

 

 

 

Figure 28: IXM WEB - Enable Genetec Link Module 

Web API URL: 

Enter the GSC WEB API URL. For example: https://localhost:4590/WebSdk 

 

User: 

Enter the name of the authorized user to connect to the Web SDK of Genetec Security Center. 

 

Password: 

Enter the Password of the authorized user to connect to the WEB SDK of Genetec Security Center 

 

Interval (Sec): 

Enter the duration of interval for data transfer between Genetec and IXM WEB. The system will 

automatically try to establish connection after every specified interval of time and sync users. 

https://localhost:4590/WebSdk
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Sync Direction: 

Click on the field to select the direction of data transfer. Data can be transferred in following three 

ways : 

• IXM WEB       Genetec 

Choosing this option will transfer data in one direction only, ie, from Genetec to IXM 

WEB. Genetec is considered as the master data in this case and any changes made in IXM 

WEB data will be overwritten during transfer. 

   Note:  

   This is the recommended option. 

 

• IXM WEB        Genetec 

Choosing this option will transfer data in one direction only, ie, from IXM WEB to Genetec. 

IXM WEB is considered as the master data in this case and any changes made in Genetec 

data will be overwritten during transfer. 

• IXM WEB         Genetec 

Choosing this option will transfer data in both the directions, ie, from Genetec to IXM WEB first 

followed by IXM WEB to Genetec.  

 

Auto Transfer: 

This option provides facility to add employee into Employee Groups in IXM WEB. For example, if there 

is an Employee Group called ‘Default Group’ in IXM WEB, then all the employees from Genetec will 

be added directly to the ‘Default Group’.  

Click on either ‘Yes’ or ‘No’. 

Yes: Selection of User Group is mandatory to use Auto Transfer. Users will be transferred to IXM 

Devices based on Sync Group configuration for selected Employee Group.  

No: Users will not be transferred to the IXM Devices.   
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Employee Group: 

➢ This option will be enabled only when ‘Auto Transfer’ is set as ‘Yes’. Otherwise it will remain 

disabled. 

A list of existing Employee Groups created in IXM WEB is displayed. Click on the Employee Group to 

which employees should be transferred automatically.  

 

Click Apply. The transfer of data between Genetec and IXM WEB is possible only after successful 

connection.  

 

 

 

 

 

 

 

 

 

 

   

In case of unsuccessful connection, please refer to the Troubleshooting section. 

After applying your changes, you should see items being updated on the screen below: 

 

 

 

 

 

 

 

 

Figure 30: IXM WEB - Sync Activities 

Figure 29: IXM WEB – Link Settings Saved 
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Numbers 

The first two colums display the number of records added, updated and deleted in Genetec and IXM 

WEB respectively after each data transfer. 

Times 

The last column displays the time when the data was transferred last.  

It also shows the time when the data will be transferred next. It is calculated as per the specified 

Interval. 

  

STEP 3 

Clicking Sync Now immediately starts synchronizing pending data. This is useful when you do not 

want to wait until the next scheduled run shown by “Next Run At”. 

 

STEP 4 

The Sync All feature allows resynchronization of database from GSC to IXM WEB. This will re-import 

missing cardholders or updated cardholders from GSC to IXM WEB. Also, it will delete IXM WEB 

employee records according to cardholders available in GSC. 

➢ The Sync All button will be visible only when the sync direction is selected as Genetec to IXM 

WEB (One-way sync). 

 

RESULT 

When data is syncing at the given interval, the numbers in view will change accordingly. 

 

STEP 5 

The Download IXM WEB Add-On feature allows to download and set up installation on each 

machine where Config Tool is available for enrollment of biometric templates from LINK view. 
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11. Installing IXM WEB Add-On 

Download IXM WEB Add-On exe 

 

Procedure 

STEP 1 

Log into IXM WEB. 

 

 

 

Figure 31: IXM WEB - Enter Login Credentials 
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STEP 2 

From Home, expand the Left Navigation Pane, Go to the Link tab. Click on Security Center 

(Genetec). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 32: IXM WEB – Link Menu 
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STEP 3 

Click Download IXM WEB Add-On to download the executable file.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: The executable file should be downloaded on the same path as that of Genetec server. 

 

 

 

 

 

 

 

 

 

Figure 33: IXM WEB – Download IXM WEB Add-On 
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Install IXM WEB Add-On 

 

Procedure 

STEP 1 

Double click on the downloaded IXM WEB Add-On file in its path to start the Setup Wizard. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Next.  

 

 

 

 

 

 

 

 

Figure 34: IXM WEB – Add-On Setup Wizard 
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STEP 2 

The installer will install IXM WEB Add-On to the default folder. To install to a different folder, enter the 

path or click ‘Browse’. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Next. 

 

 

 

 

 

 

 

 

 

Figure 35: IXM WEB – Select Installation Folder 
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STEP 3 

The installer is ready to install IXM WEB Add-On on the given path. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Next. 

 

 

 

 

 

 

 

Figure 36: IXM WEB – Confirm Installation 
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STEP 4 

Installation of IXM WEB Add-On is complete. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Close. 

 

 

 

 

 

 

 

Figure 37: IXM WEB – Add-On Installation Complete 
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12. Create System User(s) for Biometric Enrollment 

Creating System User(s) for Biometric Enrollment  

 

Procedure 

STEP 1 

Log into IXM WEB. 

On the home page, expand the Left Navigation Pane → System. The application will redirect to the 

System Users window. 

 

 

 

 

 

 

 

 

 

Figure 38: IXM WEB - Create System User 
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STEP 2 

Click Add New. 

 

 

 

 

 

 

 

 

 

Figure 39: IXM WEB - Add New System User 

 

Creating a system user requires the following details: 

• Login type 

i. Local employee 

ii. Domain employee 

• Invixium ID (User ID) (For domain employee login types, the User ID is automatically filled 

from AD) 

• Password creation (For domain employee login types, password creation is not required) 

• Email address 

• Status 

• Permission for modules 
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STEP 3 

Select Login Type (Local or Domain Employee) from the dropdown list. 

 

 

 

 

 

 

 

 

 

 

Figure 40: IXM WEB - New System User 



 
 
 
 
 
 
 

XAD-TPI-007-03G 
55 

STEP 4 

Add an email address. 

Apply for permission as “All” for Employee & Employee Group module.  

Click Save. 

 

 

 

 

 

Figure 41: IXM WEB - Save System User 
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13. Add and Configure Invixium Readers 

Adding an Invixium Reader in IXM WEB 

Procedure 

STEP 1 

From Home, click the Devices tab. 

 

 

 

 

 

 

Figure 42: IXM WEB - Devices Tab 
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STEP 2 

Select the Add Device button on the right-hand side of the page. Then select the Ethernet Discovery 

option and add the reader’s IP in the start IP section. Click on Search to find the device. 

 

 

 

 

 

 

 

 

 

 

Figure 43: IXM WEB - Search Device Using IP Address  
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STEP 3 

Once the device is found, click on it. Add the required fields and select Register. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 44: IXM WEB - Register Device 

 

STEP 4 

Name the device exactly as the name of the door it will be used for. 

 

Device Mode: select accordingly. 

Device Group: select the Access Group to which the reader will be assigned. 
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STEP 5 

Once the device has successfully been registered, click Done. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 45: IXM WEB - Device Registration Complete 
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Go to Dashboard and confirm that the Device Status chart indicates that the reader is online (ie. 

hovering will tell you how many devices are online). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 46: IXM WEB - Dashboard, Device Status 
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14. Adding an Invixium Device to a Device Group 

Procedure 

STEP 1 

Go to Devices → Groups. 

Add the device from the Right Side pane to the respective Device Group. 

 

 

 

 

 

 

 

 

 

 

Figure 47: IXM WEB - Assign Device Group 
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Configuring Wiegand to Assign Invixium Readers 

Note: Invixium devices support upto 512 bit long Wiegand format. Accordingly, you can create a 

Wiegand format as per your requirement. 

 

STEP 1 

From Home >> Expand the Left Navigation Pane >> Navigate to the General Settings tab >> Click 

the Wiegand app to open the Wiegand Format settings. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 48: IXM WEB - Create Wiegand Format 
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STEP 2 

Hover mouse over Create and select the Custom option from the dropdown menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

STEP 3 

Enter Name of the custom Wiegand and assign Bits. Lets say we name the Wiegand as ‘32-BIT CSN’ 

and define Total Bits as 32 bits where all the 32 bits are ID bits.  

 

 

 

 

 

 

 

 

Figure 49: IXM WEB - Create Custom Wiegand Format 

Figure 50: IXM WEB - Custom Wiegand Format 
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STEP 4 

Click Next and Save. Wiegand Format created message will be displayed. 

 

 

 

 

 

 

 

 

 

STEP 5 

Click on Upload and select the device group (applies to all readers). Click OK. 

 

 

 

 

 

 

 

Figure 52: IXM WEB - Upload Wiegand Format 

 

 

 

Figure 51: IXM WEB – Custom Wiegand Format Created 
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Assign Wiegand to Invixium Readers 

Note: Face and finger will always give a Wiegand output based on the initial card that was synced 

from Genetec to Invixium. 

The created Wiegand will be used to define which output format will be sent to GSC. 

STEP 1 

From Home > click the Devices tab. Select any device. 

 

 

STEP 2 

Navigate to the Access Control tab. 

 

 

 

 

 

 

 
 

 

Figure 53: IXM WEB - Navigate to Access Control Tab 
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STEP 3 

Scroll down and click on Wiegand Output and toggle the switch on the top right-hand side to enable 

Wiegand Output for the device. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 54: IXM WEB - Wiegand Output 

ID types for Wiegand output are as follows: 

1. Employee ID 

2. Default Card 

3. Actual Card 

 

Set ID Type of output Wiegand to Employee ID/Default/Actual Card. By default, Employee ID is 

selected in Wiegand Event.  

As the Employee ID field is not available in GSC, select either Default Card or Actual Card. 

Empoyee ID: This is auto generated ID by IXM WEB for an imported cardholder in Genetec.  
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Actual Card: When more than one card is assigned to the cardholder, and you want to generate 

Wiegand output data for the same card which is presented on the Invixium device. 

Default Card: It will generate Wiegand output data for the card which is marked as the default. 

Note: For fingerprint and face access, default card Wiegand output data will be generated. 

 

STEP 4 

Select desired format for Identification, Verification, Employees not found, Thermal Authentication and 

Mask not Detected for the selected Card. 

 

STEP 5 

Click Apply. 

 

 

 

 

 

 

Figure 55: IXM WEB - Save Output Wiegand 

 

RESULT  

The Wiegand Output settings of the selected device are now updated. 
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Note: 

 

▪ If you have more devices, follow the next steps to copy all Wiegand settings to all devices 

simultaneously. Note: This copies all Wiegand output settings. See Appendix C for more 

information. 

 

▪ If the cardholder was assigned multiple cards, the first assigned card will be the ‘default’ 

selected card. The details of the card will be sent as the Wiegand bits input to Genetec 

Controller. 

 

▪ To make this Wiegand output work on Genetec, you will need to make sure the Wiegand 
format is available in Genetec for use on the controllers talking to the Invixium reader (by 
Wiegand or OSDP or RIO). 
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Configuring Panel Feedback with Genetec 

Procedure 

STEP 1 

Connect Wiegand Data D0 of the Genetec Panel with WDATA_OUT0 of the IXM device, Wiegand 

Data D1 of the Genetec Panel with WDATA_OUT1, and Wiegand Ground of the Genetec Panel with 

WGND of the IXM Device. 

 

STEP 2 

Connect the LED of the Genetec Panel with ACP_LED1 of the IXM device. 

 

STEP 3 

On the Devices tab, select the required device and navigate to the Access Control tab. Scroll down 

and click on Panel Feedback. 

 

 

 

 

 

 

 

Figure 56: IXM WEB - Panel Feedback 
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STEP 4 

By default, Panel Feedback is turned OFF. Toggle the Panel Feedback switch on the top right-hand 

side to the ON position, and then enable LED Control by the panel and set the LED Mode to One 

LED. 

 

 

 

 

 

 

 

 

 

 

 

Figure 57: IXM WEB - Configuring Panel Feedback in IXM WEB 

 

STEP 5 

Click Apply. 

 

 

 

 

 

 

 

Figure 58: IXM WEB - Save Panel Feedback  
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Configuring Thermal Settings 

Note: confirm your device is capable of temperature screening first. 

 

Procedure 

STEP 1 

Click the Devices tab → Select Device → Select Thermal Settings → Thermal Authentication 

Settings to view default settings. 

 

 

 

 

 

 

 

 

 

 

 

Figure 59: IXM WEB - Thermal Settings 

STEP 2 

The list of settings along with their functions are: 
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• Temperature Unit: IXM WEB supports Celsius and Fahrenheit temperature units. By default, 

the selected option will be Fahrenheit. 

 

• Threshold Temperature: Users can set a threshold temperature. Elevated Body Temperature 

(EBT) workflows will trigger when any user whose temperature is above the threshold value. 

The default threshold temperature is 100.4 degrees Fahrenheit. 

 

• Sensitivity: Users can set Thermal Sensitivity to low or high. 

 

• Authentication Mode: The user will have two options for the Mode of authentication Soft / 

Strict, this mode of authentication is used to control the access of the user if fever is detected. 

The default mode of authentication is Strict. 

 

o Soft: Access will be granted to the End-user even after the fever is detected.  

 

o Strict: Access will be denied if the fever is detected.  

 

• Send Wiegand: This setting will be visible only if the user selects the “Strict” Authentication 

Mode. Enabling this setting will generate Wiegand whenever “High Face Temperature” is 

detected in the authentication process. 

 

• Capture Image on EBT: Enable this setting to capture the image of the user if EBT is detected. 

By default, this setting will remain disabled. The same image will be used for sending email 

notifications from IXM WEB. 

 

• Duress Status: Enabling this setting will allow access to the user even after detecting EBT if 

the user authenticates using their pre-programmed duress finger. The default setting is 

disabled.  

 

• Show Temperature on LCD: By enabling this setting, TITAN will display the screened 

temperature upon authentication. By default, this setting is disabled. 

 

• Display Message on EBT: Users can set a message to display after detecting EBT. Users can 

set a message up to a maximum of 50 characters. 

 

• EBT Display Message Time (sec): Users can configure the length of time that the EBT 

message stays on the screen. The default time is 3 seconds. 
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• Second Trial on EBT: By enabling this setting, users will get a notification to retry after EBT 

detection. If this setting is enabled, Display Message for Second Trial, Second Trial Wait Time 

after EBT (mins), and Display Message Time After Second Trial (sec) fields will be visible. 

 

• Display Message for Second Trial: Users can set a message to display after the second trial 

if EBT is detected. This message can be a maximum of 50 characters.  

 

• Second Trial Display Message Time (sec): Users can configure the length of time that the 

second trial message stays on the screen. The default time is 3 seconds. 

 

• Enable Visitor Screening: Enable this setting to start screening temperatures for visitors. By 

default, this field remains disabled. 

 

• Visitor Screening Message: Users can set a message that will be displayed when a visitor is 

showing their face. Maximum 50 characters allowed. 

 

• Visitor Screening Message on EBT: Users can set a message that will be displayed when the 

visitor has an EBT. Maximum 50 characters allowed. 

 

• Visitor Message Display Time (sec): Users can configure the length of time that the visitor 

screening message stays on the screen. The default time is 3 seconds. 

 

• Thermal on VoIP Call: Enable this setting to start screening temperatures for a user when a 

VoIP call is going on. By default, this field remains disabled. 

 

• Temperature Logging: This setting keeps logging detected temperature in the Transaction 

Log. By default, this field remains enabled. Users can disable this feature using IXM WEB only. 

Enable/Disable this setting is not available in LCD. 
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STEP 3 

Once all the settings have been configured, click Apply, then click OK. 

 

 

 

 

 

 

 

 

 

Figure 60: IXM WEB - Save Thermal Settings 
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Thermal Calibration 

STEP 1 

Click the Devices tab → Select Device → Select Thermal Settings → Thermal Calibration to view 

default settings. 

 

 

 

 

 

 

 

 

 

Figure 61: IXM WEB - Thermal Calibration Settings 

STEP 2 

The settings along with their functions are: 

• Thermal Calibration Type:  

o Manual 

o Face 

o Black Body 

 

Invixium supports only Manual Thermal Calibration and does not recommend the user to select any 

other option. 
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• Offset X (Thermal Section): Users can set the value for the offset X coordinate of the TIR 

camera. 

 

• Offset Y (Thermal Section): Users can set the value for the offset Y coordinate of the TIR 

camera. 

 

• Offset X (Optical Section): Users can set the value for the offset X coordinate of the TITAN 

camera. 

 

• Offset Y (Optical Section): Users can set the value for the offset Y coordinate of the TITAN 

camera. 

 

STEP 3 

Once all the settings have been configured, click Apply, then click OK. 

 

 

 

 

 

 

Figure 62: IXM WEB - Save Thermal Calibration Settings 
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To provide the Thermal Data to the Invixium Technical Services team using IXM WEB, the user needs 

to click Capture Thermal Data. It will open the popup window and ask the user to show their face 3 

times. 

 

 

 

 

 

 

 

 

 

Figure 63: IXM WEB - Capture Thermal Data 
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STEP 4 

Once the face is captured 3 times, it will ask the user to save the “.zip” file.  

 

 

 

 

 

 

 

 

 

 

 
 

Figure 64: IXM WEB - Save Captured Thermal Data 

 

STEP 5 

Click Save to store the zip file, then send this file to support@invixium.com. Invixium’s Technical 

Services team will process this file and respond to the user with calibrated values for “X” & “Y” 

coordinates for the TIR camera and TITAN camera. 

 

mailto:support@invixium.com
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Note: TITAN and the Enhancement kit are factory calibrated when purchased as a bundle. If thermal 
offset and optical offset values are 0, they capture thermal data. 

Test Calibration Options 

 

To test Thermal Calibration, click Test Calibration.  

 

 
 

 

 

 

 

 

 

Figure 65: IXM WEB - Test Thermal Calibration 

 

Note: Square box position should be in the center and cover the tear duct area (Eye Inner Canthus).  
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Change Temperature Unit Settings 

 

STEP 1 

To change the Temperature Unit from Celsius to Fahrenheit and vice-versa, click Tools → Options → 

Manage Preferences. 

 

 

 

 

 

 

 

 

Figure 66: IXM WEB - Option to Change Temperature Unit 
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STEP 2 

Click Save. 

 

Note: Temperature Test failure event in GSC Alarm Viewer will show the Temperature Value as per 

the Temperature Unit selection. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 67: IXM WEB - Save Temperature Unit Setting 
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Configuring Mask Authentication Settings 

STEP 1 

Click the Devices tab → Select Device → Select General Settings → Mask Authentication 

Settings to view default settings. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 68: IXM WEB - Mask Authentication Settings 
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STEP 2 

The list of settings is: 

 

• Authentication Mode: There are two options for the mode of authentication used to control 

the access workflow if a mask is not detected. The default mode of authentication is strict.  

 

o Soft: Access will be granted to the user even if a mask is not detected. 

 

o Strict: Access will be denied if a mask is not detected.  

 

• Duress Status: Enabling this setting would allow access to the user if a mask was not 

detected if the user authenticates using their pre-programmed duress finger. The default 

setting is disabled.  

 

• Capture Image if Mask Missing: Enable this setting to capture an image of the user if a mask 

is not detected. By default, this setting is disabled. The same image will be used for sending 

email notifications from IXM WEB. 

 

• Log Mask Detection Data: This setting tracks mask detection in the transaction log. By 

default, this setting is enabled. You can disable this feature using IXM WEB only, not on the 

device’s LCD. 

 

• Send Wiegand: This setting will be visible only in “Strict” authentication mode. Enabling this 

setting will generate Wiegand whenever a mask is not detected in the authentication process. 

 

• Missing Mask Warning Message: Set a message to display after a mask is not detected. The 

message can be up to 50 characters. 

 

• Missing Mask Warning Message Timeout (sec): Configure the length of time that the mask 

is not detected message stays on the screen. The default time is 3 seconds. 

 

• Enable Full Face Identification: Invixium Periocular algorithms can achieve accurate 

identification using only the eye and eyebrow regions of the face. Full face identification is 

used to get more accuracy in authentication and capture a user’s face without a mask in the 

image log. By default, this setting is disabled. 
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• Remove Mask Display Message: Set a message to display after a mask is detected when 

Full Face Identification is enabled. Messages can be up to 50 characters. 

 

• Remove Mask Display Message Time (sec): Configure the length of time that the mask is 

detected message stays on the screen. The default time is 3 seconds. 

 

• Enable Visitor Screening: Enable this setting to start screening visitors for masks. By default, 

this field is disabled. 

 

• Visitor Screening Message: Set a message that will be displayed when a visitor is showing 

their face. Messages can be up to 50 characters. 

 

• Visitor Mask Missing Warning Message: Set a message that will be displayed when a visitor 

is screened without a mask. Messages can be up to 50 characters. 

 

• Visitor Message Display Time(sec): Configure the length of time that the visitor screening 

message stays on the screen. The default time is 3 seconds. 

 

 

STEP 3 

Once all the settings have been configured, click Apply, then click OK. 

 

 

 

 

 

 

Figure 69: IXM WEB - Save Mask Settings 
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15. Enrollment using Genetec Config Tool 

Procedure 

STEP 1 

Ensure that IXM WEB Add-On has been installed on the same path as that of Genetec server. 

  

Refer Installing IXM WEB Add-On section. 

 

Note: Entrollment can be done using Config Tool as well as Security Desk. 

 

STEP 2 

Restart the Config Tool once installation of IXM WEB Add-On is complete. You will see the icon of 

IXM WEB. 

 

STEP 3 

Click IXM WEB and Log into Config Tool using valid credentials. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 70: IXM WEB – Config Tool Logon 
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STEP 4 

Note: IXM WEB opens in a new window with a list of Genetec Cardholders.  

Enter IXM WEB URL.  Select the Browser. 

 

 

 

 

 

 

 

 

 

   Note:  

   The recommended browser is Chrome. 

 

STEP 5 

Select the desired Cardholder from the list. Click Entroll Biometric. 

 

STEP 6 

Enter credentials to log in to IXM WEB. Toggle “Keep Me Signed In” to stay signed in. 

Note: Log in to IXM WEB is required only once when you launch the enrollment viewer for the first 

time. For subsequent enrollment, this step will be skipped as you are already signed in. 

 

 

Figure 71: IXM WEB – Configure IXM WEB URL 
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Once you are logged in, repeat  STEP 5.  

 

 

 

 

 

 

 

 

 

 

Figure 72: IXM WEB – First Time Log In 
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STEP 7 

Perform Fingerprint and Face Entrollment.  

Follow Invixium Enrollment guidelines for proper enrollment of faces, fingerprints, and finger veins.  

Refer Entrollment Best Practices section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 
 

 

 

 

Figure 73: IXM WEB – Enrollment Viewer 
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16. Enrollment Best Practices 

Fingerprint Enrollment Best Practices 

▪ Invixium recommends using the index, middle, and ring fingers for enrollment. 

▪ Make sure your finger is flat and centered on the sensor scanning area. 

▪ The finger should not be at an angle and should be straight when placed on the sensor. 

▪ Ensure that the finger is not too dry or too wet. Moisten your finger during enrollment if required. 

Avoid Poor Fingerprint Conditions 

▪ Wet Finger: Wipe excessive moisture from the finger before placement.  

▪ Dry Finger: Use moisturizer or blow warm breath over the finger before placement. 

▪ Stained Finger: Wipe stains from finger before placement. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 74: Fingerprint Enrollment Best Practices 
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Fingerprint Image Samples 

 

Fingerprint 
Sample 

Result Recommendation 

 

Good Fingerprint 

Always try and get a 
good fingerprint like 
this for a good 
enrollment score 

 

Fingerprint with cuts 

Invixium recommends 
using  

Card + Biometrics or 
Card + PIN  

 

Dry finger 
Moisten finger and re-
enroll for better results 

 

Wet/Sweaty finger 
Rub finger on clean 
cotton cloth and re-
enroll for better results 

 

Figure 75: Fingerprint Images Samples 
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Fingerprint Imaging Do's and Don'ts 

Do's: 

▪ Capture the index finger first for the best quality image. If it becomes necessary to capture 

alternate fingers, use the middle or ring fingers next. Avoid pinkies and thumbs because they 

generally do not provide a high-quality image. 

▪ Ensure that the finger is flat and centered on the fingerprint scanner area. 

▪ Re-enroll a light fingerprint. If the finger is too dry, moistening the finger will improve the image. 

▪ Re-enroll a finger that has rolled left or right and provided a partial finger capture.  

 

Remember to: 

▪ Identify your fingerprint pattern. 

▪ Locate the core.  

▪ Position the core in the center of the fingerprint scanner.  

▪ Capture an acceptable quality image.  

 

Don'ts:  

▪ Don't accept a bad image that can be improved. This is especially critical during the 

enrollment process.  

▪ Don't assume your fingerprint is placed correctly. 
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Finger Vein Enrollment Best Practices 

▪ Invixium recommends using the index and middle fingers for enrollment. 

▪ Make sure your fingertip is resting on the finger guide at the back of the sensor cavity. 

▪ The finger should be completely straight for the best finger vein scan. 

▪ Ensure that the finger is not turned or rotated in any direction.  

 

 

 

 

 

 

 

 

 

 

Figure 76: Finger Vein Enrollment Best Practices 
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Face Enrollment Best Practices 

▪ Invixium recommends standing at 2 to 3 feet from the device when enrolling a face. 

▪ Make sure your entire face is within the frame corners, which will turn green upon correct 

positioning. 

▪ Look straight at the camera when enrolling your face. Avoid looking in other directions or turning 

your head during enrollment.  

 

 

 

 

 

 

 

 

 

Figure 77: Face Enrollment Best Practices 
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17. Configuring RIO Settings 

Configuring RIO in Config Tool of GSC 

Procedure 

STEP 1 

Log into Config Tool using valid credentials. 

 

STEP 2 

Creating Roles and Units. 

Navigate to Access Control → Roles and Units  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 78: Config Tool – Access Control 
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STEP 3 

Create Access Manager.   

Right click on server name → Click on Add an entity → Click on Show all → Click on Access 

Manager  

Righ click on the Machine →  Add an entity → Show all → Access Manager  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 79: Config Tool – Access Manager 



 
 
 
 
 
 
 

XAD-TPI-007-03G 
96 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Next. 

 

Click Nex 

 

 

 

 

 

 

Figure 80: Config Tool – Add Access Manager 
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Click Create. 

Access Manager is created. 

 

 

 

 

 

 

 

 

 

Figure 81: Config Tool – Access Manager created 
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Note: You need to wait till the Access Manager becomes online. 

STEP 4 

Create Access Control Unit.  

Righ click on the Access Manager →  Add an entity → Access Control Unit 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hostname or IP 

Enter the value of Hostname or IP. For example: “localhost”. 

 

Username 

Enter authorized User name to access Genetec server. 

 

Figure 82: Config Tool – Add Access Control Unit 
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Password 

Enter Password of authorized User to access Genetec server. 

Click Next and Create. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: Description should show “Unit created successfully”. 

Click Close. 

 

 

 

 

 

 

Figure 83: Config Tool – Creating Access Control Unit  
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Access Control Unit is added. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 84: Config Tool – Access Control Unit created 
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Configuring RIO in IXM WEB 

Procedure 

STEP 1 

Log into IXM WEB using valid credentials. 

 

STEP 2 

From the Left Navigation Pane → Link → click the blue Security Center (Genetec) icon. 

 

 

 

 

 

 

 

 

RIO Setting 

Click on the check box to enable wireless connection to the Control Panel.  

 

Server URL: 

Enter Address of Synergis appliance. 

 

User Name: 

Enter User name to access Synergis appliance. 

Figure 85: IXM WEB – RIO Settings 
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Password: 

Enter Password to access Synergis appliance. 

 

Synergis Name: 

Enter Synergis Name to separate Synergis appliances for setups with multiple appliances. 

 

 

Devices selected in the next step would be added to this channel on the Synergis appliance. A new 

channel will be created if required. 

 

 

 

 

 

 

 

 

 

 

 

Figure 86: IXM WEB – Channel 

Click on target sevices to select. 

 

Click Send. 
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Note: Clicking Send will add each selected Invixium device as an interface on the Synergis appliance. 
The device name will be the name of the interface. Each interface will be given an input label, “REX”, 
an output label, “Lock”, and a reader label, “Reader”.  
 
 

Configuring Invixium Device and Door in Config Tool 

 

STEP 1 

Go to Config Tool. 

 

STEP 2 

Navigate to Access Manager → Click on the created Access Control Unit → Click on Peripherals 

tab. 

You should be able to see the name of Invixium device in the format:  

Invixium – Product Type (Channel name – Invixium device name) 

 

The State of the device should be "Online". 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 87: Config Tool – Peripherals 



 
 
 
 
 
 
 

XAD-TPI-007-03G 
104 

STEP 3 

Create an Area or Door. 

Navigate to Area View → Right Click on the Server Name → Click on Add an entity → Click on Door 
 
 
 
 
 
 
 
 
 
 
 
 
 
Entity name 
 
Enter name of the Door. 
 
 
Click  Next. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 88: Config Tool – Creating a Door 

Figure 89: Config Tool – Door Information 
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Access control unit 
 
Click to select the Access control unit you created from the list. 
 
Interface module 
 
Click to select the Invixium device on which RIO settings were applied. 
 
Click  Next and Create. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click Close. 
 
 
 
 

Figure 90: Config Tool – Door is created 
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STEP 4 

Configure the Door. 

Navigate to Area View → Click on the Door created by you → navigate to Hardware tab  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note: In case of single Reader, either Door Side In can be configured or Door Side Out and not both 
of them.  
 
 
 

Figure 91: Config Tool – Configuring Door 
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Reader 
 
Click to select the Invixium device reader as External Reader. 
 
Request to exit 
 
Click to select the Invixium device as REX. 
 
Door lock 
 
Click to select the Invixium device for Door lock. 
 
 
Click Apply. 
 
 

STEP 5 

Configure the Schedule. 

Select Door which you have created → Click on Access Rules tab → Click on + icon → Click on All 

open rule  

 

 

 

 

 

 

 

 

 

 

 

 

Figure 92: Config Tool – Access Rule 
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Click OK and Apply. 

 

 

Monitoring Events and alarms 

STEP 1 

Log in to Security Desk of GSC and Navigate to Monitoring tab. 

 

STEP 2 

You will be able to see the Door that you have configured.  

Note: The View Area is empty right now. 

 

 

 

 

 

 

 

Drag and drop the Door to the   

 

 

 

 

 
Figure 93: Security Desk – Monitoring 
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STEP 3 

Drag and drop the Door to the View Area.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 94: Security Desk – View Area  
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STEP 4 

Perform authetification event on the device and verify the event on Genetec Desk. 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 95: Security Desk – Access Granted  
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18. Appendix 

Installing Invixium IXM WEB with Default Installation using SQL Server 2014 

Note:  

▪ By default, the IXM WEB installer will install SQL server 2014 

▪ It is highly recommended to use SQL server 2016 or higher 

 

If it is intended for IXM WEB to use a non-default SQL 2014 installed instance, please refer to 

Installing SQL Instance. 

 

Procedure 

STEP 1 

Run the installer.exe 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

Figure 96: Install IXM WEB  
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Note: Installs SQL 2014 Express. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Figure 97: Loading SQL Express & Installation Progress 

 

STEP 2 

Once the installation is completed, check these services to make sure they are all running: 

▪ Bonjour 

▪ Invixium Device Discovery 

▪ IXM WEB  
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STEP 3 

Run IXM WEB by selecting it from the Windows Start menu or your desktop. 

 

 

 

 

 

 

 

 

Figure 98: IXM WEB - Shortcut Icon on Desktop 

 

STEP 4 

Select Windows Authentication and the SQL Server Name, then click on Connect. 

 

 

 

 

 

 

 
 

 

Figure 99: IXM WEB - Configuring IXM WEB Database 

 

STEP 5 

Select the Database Name and then click Next. 
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Figure 100: IXM WEB - Select Database Name 

STEP 6 

Fill in the fields under the Create Account section and then select Save At Server URL. 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Figure 101: IXM WEB - Server URL format 
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STEP 7 

Use the server machine’s IP Address which will interface with the Invixium reader. 
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Pushing Configuration to Multiple Invixium Readers 

Procedure 

STEP 1 

To push these configurations to other Invixium readers, while the configured Invixium device is 

selected, click the Broadcast option on the right-hand side. 

 
 

 

 

 

Figure 102: IXM WEB - Broadcast Option 

 

STEP 2 

Scroll down to the Access Control section and check the Wiegand Output option. 

 

 

 

 

 

 

Figure 103: IXM WEB - Wiegand Output Selection in Broadcast 
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STEP 3 

Click Broadcast. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 104: IXM WEB - Broadcast Wiegand Output Settings 
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STEP 4 

Select the rest of the devices in the popup. Click OK to copy all Wiegand output settings of the source 

device to all destination devices. 

 

 

 

 

 

 

 

 

 

 

 

Figure 105: IXM WEB - Broadcast to Devices 
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Configuring for OSDP Connection 

STEP 1 

From Home, click the Devices tab. Select the required Device and navigate to Access Control. Click 

OSDP. 

By default, the OSDP configuration is turned OFF. Enable the OSDP by toggling the switch to ON. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 106: IXM WEB - OSDP Settings  
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STEP 2 

Provide values for the configuration settings below: 

 

Baud Rate 
The baud rate of the serial communication. The value 

must be the same as the Access Control Panel’s value. 

Parity Bit 
The parity bit of the serial communication. The value must 

be the same as the Access Control Panel’s value. 

Stop Bit 
The stop bit of the serial communication. The value must 

be the same as the Access Control Panel’s value. 

Enable Log 

This logs OSDP events for support and debugging 

purposes. Invixium recommends disabling this feature 

unless needed. 

SmartCard Passthru 

When presenting a smart card, the device passes the 

smart card CSN (Card Serial Number) to the Access 

Control Panel without taking any other action. 

Enable Biometric Enables biometric template verification. 

Secure Channel 

The secure key is provided by your Access Control Panel 

most of the time. However, provisions for manual entry 

can be added as TEXT or HEX. 

Event 

The OSDP static events for panel feedback and capture 

pin are: 

• Access Granted 

• Access Denied 

• Enter PIN 

Dual Authentication – It is an access mode that requires 

valid access by two authorized cardholders to enter an 

access zone within a specified time period. This feature is 

available only if the Multi-User Authentication feature is 

enabled and configured. To configure the Multi-User 

Authentication feature, from Home, click the Devices tab. 

Select the required Device and navigate to General 

Settings. Click on the Multi-User Authentication 

section. Upon enabling this feature, the following actions 

will be performed: 

• The Device will request the credentials of the second 
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user after the first user is authenticated successfully. 

• Card numbers for both, the first and the second user 

will be transferred to the Access Control Panel. 

• Two events, one for the first user and the other for the 

second user will be logged into the Access Control Panel. 

On Color/Off Color 

The LED color configuration is based on panel events. 

The value must be the same as the Access Control 

Panel’s value. Options are: 

• Red 

• Green 

• Yellow 

• Blue 

Table 5: IXM WEB - OSDP Configuration Options 

Note: Mismatches between the unit and Access Control Panel LED configuration would cause 

unrecognized events. 

 

Display OSDP Text Enables to display OSDP Text. 

Display Message 

Notification on the device’s screen. 

▪ If enabled: Displays both the unit hardcoded 
notification and the Access Control Panel notification. 

▪ IXM notification - Access Granted or Access Denied. 

▪ Access Control Panel notification – Valid or Invalid. 

▪ If disable: Displays only the Access Control Panel 
notification. 

Table 6: IXM WEB - OSDP Text Options 
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STEP 3 

Click Apply to save the settings. 

 

 

 

 

 
 

Figure 107: IXM WEB - Save OSDP Settings 

 

STEP 4 

Open the edit option on the reader and note the Device ID. This will be the address used in the 

configuration of the reader in the Security Center. 

 

 

 

 

 

 

Figure 108: IXM WEB - Edit Device 
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Figure 109: IXM WEB - Edit Device Options 

STEP 5 

Wiegand Input and output also need to be configured to allow OSDP communication to work. Create 

the same settings for Wiegand connections as you did previously. 

 

STEP 6 

Disable Panel feedback for any OSDP-connected reader to stop multiple access granted messages 

from being sent to Security Center. 

 
 

 

 

 

Figure 110: IXM WEB - Disable Panel Feedback 
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Wiring and Termination 

Procedure 

Earth Ground 

For protection against ESD, Invixium recommends the use of a ground connection between each 

Invixium device to high-quality earth ground on site. 

 

STEP 1 

Connect the green and yellow earth wire from the wired back cover. 

 

STEP 2 

Connect the open end of the earth ground wire provided in the install kit box to the building earth 

ground. 

 

STEP 3 

Screw the lug end of the earth ground. 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 111: Earth Ground Wiring 
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Wiring 

 

 

 

 

 

 

 

 

 

 

 

Figure 112: IXM TITAN – Top & Bottom Connector Wiring 
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Figure 113: Power, Wiegand & OSDP Wires 
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All Invixium devices support Wiegand, OSDP and RIO protocol (wireless). 

Invixium devices can be integrated with Genetec Controller on: 

1. Wiegand (one-way communication) 

2. Wiegand with panel feedback (two-way communication) 

3. OSDP (two-way communication) 

 

Wiegand Connection 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 114: IXM TITAN - Wiegand 

 
Please refer to the INGUIDE document provided for each product on Invixium.com under the 

Download section of the Products menu.  

  

invixium.com
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Wiegand Connection with Panel Feedback 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 115: IXM TITAN - Panel Feedback 

 
Please refer to the INGUIDE document provided for each product on Invixium.com under the 

Download section of the Products menu.  
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OSDP Connections 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 

Figure 116: IXM TITAN - OSDP Connections 

 

Please refer to the INGUIDE document provided for each product on Invixium.com under the 

Download section of the Products menu.  
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19. Troubleshooting 

Reader Offline from the IXM WEB Dashboard 

Note: Confirm communication between the IXM WEB server and the Invixium reader. 

Procedure 

STEP 1 

From Home, click the Devices tab. 

 

STEP 2 

Select any device. 

 

STEP 3 

Navigate to the Communication tab. 

 

 

 

 

 

 

 

 

 

Figure 117: IXM WEB - Device Communication Settings 
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STEP 4 

Scroll down and click on IXM WEB Server. 

Figure 118: IXM WEB - Server URL Setting 

 

Ensure the correct IP address of the server is listed here. If not, correct and apply. 

 

STEP 5 

Enter the IP address of the Invixium server followed by port 9108. 

Format: http://IP_IXMServer:9108 

 

 

 

 Figure 119: IXM WEB - Server URL Setting 

Ensure the correct IP address of the server is listed here. If not, correct and apply. 

 

STEP 5 

Enter the IP address of the Invixium server followed by port 9108. 

Format: http://IP_IXMServer:9108 
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STEP 6 

Navigate to General Settings and make sure that the URL reflects the same setting. 

Figure 120: IXM WEB - Server URL Setting from General Settings 

 

 

 

 

 

 

 

 

 

Figure 121: IXM WEB - Server URL Setting from General Settings 
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Elevated Body Temperature Denied Access but Granted Access in Security Center 

Procedure 

STEP 1 

Ensure that Thermal Authentication is selected to none from IXM WEB → Device → Access 

control settings → Wiegand Output. 

 

 

 

 

 

 

 

 

 

 

 

Figure 122: IXM WEB - Thermal Authentication Wiegand Output Event 

 

Figure 123: IXM WEB - Thermal Authentication Wiegand Output Event 

 

 

Note: If Thermal Authentication events are configured for any format, it generates Wiegand output 

accordingly for a high-temperature event. 
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Logs in IXM WEB Application 

 

Device Logs: Device Logs are used for debugging device-related issues.  

 

From Home → Click the Devices Tab on the top → Select the required Device → Navigate to the 

General Settings tab for the device → Click on Device Log → Enable Capture Device Logs. 

 

 

 

 

 

Figure 124: IXM WEB - Enable Device Logs 

Click Download to initialize the process to download the device log file. 

 

 

 

 

 

 

 

 

 

Figure 125: Save Device Log File 

Select Save File and Click OK to store the device log file on your machine. 

 

Transaction Logs (TLogs): Events or activities taking place on the IX 
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Figure 126: Save Device Log File 

 

Select Save File and Click OK to store the device log file on your machine. 

Transaction Logs (TLogs): Events or activities taking place on the IXM device. 

• Transactions Logs can be viewed and exported from IXM WEB. 

 

• Go to Logs in the Left Navigation pane in IXM WEB and click on Transaction Logs. A filter 

option is available in Transaction Logs columns. 
 

Application Logs: Applications logs are available for any event, error, or information generated in 

IXM WEB. 

 

• Applications Logs can be viewed and exported from IXM WEB. 

 

• Go to Logs in the Left Navigation pane in IXM WEB and click on Application Logs. The filter 
option is available in the Application Logs columns. 

 

Logs folder location on IXM WEB Server: 

 

IXM WEB Logs  C:\Program Files (x86)\Invixium\IXM WEB\Log 

IXM WEB Service 
Logs 

C:\Program Files (x86)\Invixium\IXMWebService 

IXM API Logs C:\Program Files (x86)\Invixium\IXMAPI\Log 

Table 7: Logs Folder Location 
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Unable to connect to the Genetec Server 

Procedure 

STEP 1 

Note: Confirm module activation 

Navigate to Licence, and check ACTIVATION HISTORY. If not there, request a Licence. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 127: IXM WEB - Licence Module 
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STEP 2 

Note: Confirm WEB SDK is enabled. 

From Link, click the Security Center tab. Ensure the correct WEB API URL of the server is listed. 

here. If not, correct and apply. 

 

 

 

 

 

 

 

 

 

 

STEP 3 

Note: Confirm parameters entered to connect to the Genetec server. 

Ensure the correct User who is authorized to connect to the WEB SDK of Genetec Security Center is 

listed here. If not, correct and apply. 

Ensure the correct Password of the user who is authorized to connect to the WEB SDK of Genetec 

Security Center is listed here. If not, correct and apply. 

 

Note: If you are still facing problem with connection, please email logtxt.txt file to 
support@invixium.com. 

This file is available at the following path:  

Program Files (x86)\Invixium\IXM WEB\Log 

 

Figure 128: IXM WEB - Genetec Link Module 

mailto:support@invixium.com
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20.  Support 

For more information relating to this document, please contact support@invixium.com. 

 

 

21. Disclaimer and Restrictions 

This document and the information described throughout are provided in their present condition and 

are delivered without written, expressed, or implied commitments by Invixium. and are subject to 

change without notice. The information and technical data herein are strictly prohibited for the 

intention of reverse engineering and shall not be disclosed to parties for procurement or 

manufacturing. 

This document may contain unintentional typos or inaccuracies. 

 

TRADEMARKS 

The trademarks specified throughout the document are registered trademarks of Invixium. All third-

party trademarks referenced herein are recognized to be trademarks of their respective holders or 

manufacturers. 

 

Copyright © 2023 Invixium. All rights reserved. 
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